ma banniere
Classic Moderne

Erreur NO_PUBKEY


W: Erreur de GPG : …/… NO_PUBKEY …

Voici ce que l'on peut obtenir comme erreur dans le terminal, aprés avoir fait un sudo apt-get update

W: Erreur de GPG : http://deb.opera.com stable Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY AAFF4A5B336064B5

Cette commande devrait résoudre le problème :

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com <n°_de_clé>

ou bien :

sudo apt-get install add-apt-key && sudo add-apt-key <n°_de_clé>

Elle est utilisable pour toute erreur de ce type ; il suffit de modifier le code clé qui vous ai donné par le retour d'erreur du terminal.

soit =>

sudo apt-key adv –recv-keys –keyserver keyserver.ubuntu.com le code clé

pour faire la mise à jour =>

sudo apt-get update && sudo apt-get upgrade -y



Message d'erreur

Comment ajouter le dépôt de Getdeb

Méthode facile: il suffit d'installer le paquet getdeb-repository disponible sur le site Getdeb ou de coller dans un terminal

sudo echo "deb http://archive.getdeb.net/ubuntu `lsb_release -cs`-getdeb games" | sudo tee /etc/apt/sources.list.d/getdeb.list && wget -q http://archive.getdeb.net/getdeb-archive.key -O- | sudo apt-key add -

Méthode plus complexe: il suffit d'ajouter le dépôt suivant (changez "precise" par votre version d' Ubuntu) :

- Alt+F2
- gksu nautilus
- Se déplacer vers /etc/apt/sources.list.d/getdeb.list puis éditer getdeb.list en ajoutant les lignes en gras ci-dessous:

Pour les programmes:
deb http://archive.getdeb.net/ubuntu precise-getdeb apps

Pour les jeux:
deb http://archive.getdeb.net/ubuntu precise-getdeb games






Haut-de-Page